debian安装网易云解决依赖问题

Introduction

心血来潮又想用桌面的网易云了。很早之前把系统更新到了debian sid。记得之前还发微博说

debian8 要用ubuntu 14.04版本

但是现在安装发现不行了,依赖问题。现记录问题解决方案。

同时,在安装其他软件时,如果出现依赖问题,可以尝试用本文方法进行跳过。

我的系统:

PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
NAME="Debian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=debian
HOME_URL="https://www.debian.org/"
SUPPORT_URL="https://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"

64位 32位问题

如果是64位系统安装32位的网易云,需要安装各种32位的包,而且冲突的可能性很大。不建议。

在出现依赖问题后,sudo apt-get -f install会尝试自动解决依赖问题,但是如果它解决不了,就会建议你卸载这个包。手动解决依赖必须先卸载这个包,解决完成后,再装网易云的包。

ubuntu 14.04版本问题

这个版本的包一直纠结于gstreamer0.10-plugins-的几个包,但是debian 9的已经到了gstreamer1.0-plugins-,旧包自然被抛弃了,在debian sid的库里搜索这个包发现已经标记了debports(弃用)

可以尝试下载旧包强制安装(不建议,但是有时对部分软件还是挺有效的,因为对于这个方法,我的使用原则是,如果安装旧包没有冲突产生,就可以安装)。

我下载旧包安装之后,出现了依赖冲突,无法解决,放弃强制安装旧包的方法。

Ubuntu 16.04的包

主要问题两个libqt5libqgtk2、libfontconfig1 (>= 2.11.94),而在装完包之后apt已经告诉了

没有可用的软件包 libqt5libqgtk2,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
然而下列软件包会取代它:
  qt5-style-plugins:i386 qt5-style-plugins

系统中这两个包已经默认安装了。

而且ubuntu16.04是比较新的版本,debian stretch和它的环境比较接近。因此它的依赖问题少很多。

下面采用Linux完美使用deepin QQ 2. 简单移植deepin的wine软件包到其他Linux发行版 部分的方法。

修改依赖重新打包

# 先创建软件包目录
mkdir -p extract/DEBIAN
# 用dpkg解压
dpkg-deb -x neteasemusic.deb extract/
dpkg-deb -e neteasemusic extract/DEBIAN

用文本编辑器打开extract/DEBIAN/control,找到Depends行,删除libqt5libqgtk2,删除libfontconfig1 (>= 2.11.94)中的(>= 2.11.94),然后重新打包:

# 建立软件包生成目录
mkdir build
# 重新打包
dpkg-deb -b extract/ build/

在build目录下会看到新生成的包。安装这个新的包即可。

无法运行

从命令行运行时发现提示错误:

The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /usr/lib/netease-cloud-music/chrome-sandbox is owned by root and has mode 4755.

按照提示修改:

cd /usr/lib/netease-cloud-music/
sudo chown root.root chrome-sandbox 
sudo chmod 4755 chrome-sandbox

运行正常。

路漫漫其修远兮,吾将上下而求索

文章若未注明转载皆为原创,如需转载请注明出处FindHao博客及文章链接,文章markdown格式源码现已开放,欢迎转载。文章源码地址:

分享到:

You may like..(由于采用了谷歌的推荐系统,需要对本站关闭广告过滤~)

Find

新浪微博(FindSpace博客)QQ群:不安分的Coder(375670127) 不安分的Coder

2 条回复

  1. nightwatch说道:

    谢谢这篇博文。实测中解deepin 15的包会好一点,不需要改libfontconfig1的依赖了,只有libqt5libgtk这个包不满足要求。
    另外,可否转载这篇文章?会著明出处及原文链接。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

*