Ubuntu搭建LAMP

为了数据库课程设计,只好自己搭一个数据库系统,采用LAMP方式。

一、安装

1.安装Apache

sudo apt-get install apache2

Apache在安装期间会新建一个目录:/var/www,该目录是该服务器中存放文档的根目录。

2.安装MySQL

sudo apt-get install mysql-server  

(版本号可以省略,自动查找新版。)

在安装的最后会提示输入mysql的root密码

3. 安装PHP

sudo apt-get install php5 libapache2-mod-php5

重启Apache,让它加载PHP模块

sudo /etc/init.d/apache2 restart

4. 安装phpMyAdmin

sudoapt-get install phpmyadmin

安装时会提示新建一个数据库,可以选是也可以不安装

 

二、配置

1、配置Apache

sudo gedit /etc/apache2/apache2.conf在文档的最后,

添加文件类型支持:

AddType application/x-httpd-php .php .htm .html

(根据自己需要)默认字符集:AddDefaultCharset UFT-8

(根据需要)添加首页文件 三个的顺序可以换 前面的访问优先:

<IfModuledir_module>

DirectoryIndex index.htm index.html index.php

</IfModule>

完成后重启apache配置生效:sudo /etc/init.d/apache2 restart

2. 配置PHP5

sudogedit /etc/php5/apache2/php.ini

根据自己需要,下面是默认时区

;date.timezone=  换成

date.timezone = PRC

 

3.配置mysql

sudogedit /etc/mysql/my.cnf

默认是只允许本地访问数据库的,如呆有需要其他机器访问,把这句话用#号注释掉

 bind-address 127.0.0.1

4.配置phpmyadmin

phpmyadmin默认并不是安装在/var/www下面的,而是在/usr/share/phpmyadmin,可以把phpmyadmin复制到/var/www

代码:sudo cp -r /usr/share/phpmyadmin /var/www/phpmyadmin,

然后在终端里运行:

sudo gedit /etc/phpmyadmin/apache.conf

把下面两句中的/usr/share/phpmyadmin路径改为/var/www/phpmyadmin

Alias /phpmyadmin /usr/share/phpmyadmin

<Directory/usr/share/phpmyadmin>

三、测试

1. 测试Apache

输入:http://localhost/看是否出现It works字样

2. 测试MySQL

输入:sudo netstat -tap | grep mysql

可以看到类似下面的行:

tcp 0 0 localhost:mysql *:*LISTEN 4477/mysqld

 

如果服务器不能正常运行,您可以通过下列命令启动它:sudo /etc/init.d/mysql restart

3. 测试PHP

UbuntuApache的根目录位于/var/www中

在里面添加一个测试文件test.php文件,

内容为:

<?php

phpinfo();

?>

浏览器重输入http://localhost/test.php,如果出现了一个显示PHP运行参数的页面,那就说明PHP已经正常运行了。

4.测试phpmyadmin

在浏览器中输入http://localhost/phpmyadmin可以访问说明配置好了,然后以root为用户名,以安装phpmyadmin途中输入的密码为密码. 登入phpmyadmin,这个时候,就可以自由创建数据库和数据库用户

 

注意:如果此时在http://localhost/phpmyadmin是一个空白页面,那么打开php.ini,把其中的display_errors = Off调整为display_errors = On,并重启重启apache。

sudo gedit /etc/php5/apache2/php.ini      #找到display_errors并改正之。

sudo /etc/init.d/apache2 restart     #重启apache2,启用调整后的php.ini

如果你是按照如上步骤安装的,那么在打开phpmyadmin的时候,应该会显示

Fatal error: require_once(): Failed opening required ‘./libraries/php-gettext/gettext.inc’ (include_path=’.’) in /var/www/phpmyadmin/libraries/select_lang.lib.php on line 395

可以这样解决:

 

sudo rm /var/www/phpmyadmin/libraries/php-gettext/*    #这一步是删除软连接
sudo ln /usr/share/php/php-gettext/* /var/www/phpmyadmin/libraries/php-gettext    #这一步是建立硬链接

 

 

 

Reference:

最后那个问题的解决

http://superuser.com/questions/590208/phpmyadmin-symlinks-error-after-ubuntu-upgrade

http://www.linuxdiyf.com/viewarticle.php?id=186105

Apache的wiki

 

http://wiki.ubuntu.org.cn/index.php?title=Apache&variant=zh-cn#.E9.85.8D.E7.BD.AEapache

 

 

wordpress的安装很简单,可以直接参看官网的,这里给出解决升级和安装插件等的需要输入什么ftp用户名和密码的解决方法

原因是因为apache和当前文件的onwer不同,可以先通过cat /etc/passwd来查看你服务器跑的是www还是www-data用户然后

 

 

sudo  chown  -R  www-data /var/www/wordpress

sudo  chmod -R 775 /var/www/wordpress

 

 

Reference

http://blog.csdn.net/authorzhh/article/details/8033510

文章版权归 FindHao 所有丨本站默认采用CC-BY-NC-SA 4.0协议进行授权|
转载必须包含本声明,并以超链接形式注明作者 FindHao 和本文原始地址:
https://www.findhao.net/res/131

你可能喜欢:(相似内容推荐和广告都使用了谷歌的推荐系统,需要对本站取消广告屏蔽才能显示。感谢点击↓广告支持博主~)

Find

新浪微博(FindHaoX86)QQ群:不安分的Coder(375670127) 不安分的Coder

发表评论

电子邮件地址不会被公开。 必填项已用*标注

*